Mostrar duplicados en otra columna

En la mayoria de casos cuando utilizamos las funciones en Excel necesitamos obtener resultados  especificos según el manejo de información que tenemos, para este tipo de problemas pueden existir diferentes resultados. En el siguiente ejercicio planteamos uno de tantos.

Este caso es un problema que le surgio a uno de nuestros alumnos, aqui va la solución planteada.

Temenos un listado con 4 columnas. Nos pide crear una fórmula en la columna SITUACIÓN donde:

  • Aparezca las palabras APROBADO, EN ESPERA o PENDIENTE si el valor de la columna DESCRIPCIÓN esta duplicado en toda la lista.
  • Deben aparecer estas palabras según el producto.
  • Debe aparecer en blanco la celda si el producto no se duplica.

Según la información recaudada sabemos que solo se duplican estos tres productos.

Para resolver este problema, es necesario hallar los registros duplicados y apartir de este resultado mostrar las palabras APROBADO, EN ESPERA y PENDIENTE.

Es necesario conocer el manejo de las siguientes funciones para la resolución de este ejercicio:

  • CONTAR.SI ()
  • SI()
  • BUSCARV ()

Lo haremos en 3 pasos:

1º PASO: HALLAR LOS REGISTROS DUPLICADOS

Para hallar los registros duplicados haremos uso de CONTAR.SI (). Esta función nos permite indentificar en la columna de SITUACIÓN, los registros que se repiten.  

 

2)  PASO: Colocar la palabra APROBADO, EN ESPERA o PENDIENTE en la columna SITUACIÓN

Para ello utilizamos la función SI () y BUSCARV ()

 

 

Entonces la fórmula nos queda: 

=SI (CONTAR.SI (C$3:C3; C3)>=2;BUSCARV(C3;$C$3:$D$11;2;0);D3)

 

3) PASO: En este último paso vamos a cambiar los ceros por vacíos

Entonces en la columna SITUACIÓN nos queda de la siguiente manera:

=SI(SI(CONTAR.SI(C$3:C3;C3)>=2;BUSCARV(C3;$C$3:$D$11;2;0);D3)=0;””;SI(CONTAR.SI(C$3:C3;C3)>=2;BUSCARV(C3;$C$3:$D$11;2;0);D3))

 

Con esto logramos lo solicitado por nuestros alumno.

“Si quieres aprender más sobre EXCEL matricúlate en nuestros próximos cursos”.

 

Revisa nuestros próximos cursos: CALENDARIO DE CURSOS o solicitar información en el siguiente link.

Si te gusto este artículo
Llamanos!